Open Source im professionellen Einsatz

DFN-CERT-2017-1802 WordPress: Mehrere Schwachstellen ermöglichen u.a. die Durchführung von Path-Traversal-Angriffen [Linux][Debian]

12.10.2017

Liebe Kolleginnen und Kollegen,

bitte beachten Sie die folgende Sicherheitsmeldung.

Betroffene Software:

WordPress <= 4.8.2


Betroffene Plattformen:

Debian Linux 8.9 Jessie
Debian Linux 9.2 Stretch
Debian Linux 10.0 Buster



Mehrere Schwachstellen in WordPress ermöglichen einem entfernten, nicht
authentisierten Angreifer die Durchführung verschiedener
Cross-Site-Scripting (XSS)-, Open-Redirect- und Path-Traversal-Angriffe,
einen SQL-Injection-Angriff sowie das Erlangen von Benutzerrechten
(CVE-2017-14990).

Der Hersteller hatte die WordPress Version 4.8.2 zur Behebung der
Schwachstellen CVE-2017-14718 bis CVE-2017-14726 und einiger weiterer
Probleme als 'Security and Maintenance Release' veröffentlicht.

Debian stellt nun Sicherheitsupdates für die Distributionen Jessie
(oldstable), Stretch (stable) und Buster (testing) zur Verfügung, durch
welche zusätzlich zu den in WordPress 4.8.2 als behoben genannten
Schwachstellen die Schwachstelle CVE-2017-14990 adressiert wird.


Patch:

Debian Security Advisory DSA-3997-1

<https://www.debian.org/security/2017/dsa-3997>


CVE-2017-14990: Schwachstelle in WordPress ermöglicht Erlangen von
Benutzerrechten

WordPress 4.8.2 speichert 'wp_signups.activation_key'-Werte im Klartext
(speichert aber die entsprechenden 'wp_users.user_activation_key'-Werte als
Hashes). Dies macht es für einen Angreifer einfacher nicht aktivierte
Benutzerkonten zu übernehmen, indem er lesenden Zugriff auf die Datenbank
nutzt (wie etwa Zugriff über eine nicht spezifizierte
SQL-Injection-Schwachstelle). Ein entfernter, nicht authentisierter
Angreifer kann die Schwachstelle für das Erlangen von Benutzerrechten
ausnutzen.


CVE-2017-14726: Schwachstelle in WordPress ermöglicht
Cross-Site-Scripting-Angriff

Im 'Visual Editor' von WordPress vor 4.8.2 existiert eine nicht näher
beschriebene Schwachstelle. Ein entfernter, nicht authentisierter Angreifer
kann diese ausnutzen, um einen Cross-Site-Scripting (XSS)-Angriff
durchzuführen.


CVE-2017-14725: Schwachstelle in WordPress ermöglicht Open-Redirect-Angriff

In den Bildschirmansichten zum Editieren von Benutzern und Bedingungen (User
and Term Edit Screens) von WordPress vor 4.8.2 existiert eine nicht näher
beschriebene Schwachstelle. Ein Angreifer kann diese ausnutzen, um Benutzer
des Systems auf beliebige externe Webseiten umzuleiten. Diese Schwachstelle
kann als Ausgangspunkt für die Durchführung von Phishing-Angriffen
ausgenutzt werden. Ein entfernter, einfach authentisierter Angreifer kann
einen Open-Redirect-Angriff durchführen.


CVE-2017-14724: Schwachstelle in WordPress ermöglicht
Cross-Site-Scripting-Angriff

In der 'oEmbed discovery'-Funktionalität von WordPress vor 4.8.2 existiert
eine nicht näher beschriebene Schwachstelle. Ein entfernter, nicht
authentisierter Angreifer kann diese ausnutzen, um einen
Cross-Site-Scripting (XSS)-Angriff durchzuführen.


CVE-2017-14723: Schwachstelle in WordPress ermöglicht SQL-Injection-Angriff

Die Funktion '$wpdb->prepare()' von WordPress vor 4.8.2 kann unerwartete und
unsichere Anfragen erzeugen, wodurch eine SQL-Injection (SQLi) möglich ist.
WordPress Core ist nicht direkt verwundbar, aber Plugins und Themes könnten
versehentlich die Schwachstelle hervorrufen. Ein entfernter, nicht
authentisierter Angreifer kann diese Schwachstelle ausnutzen, um SQL
Statements einzuschleusen.


CVE-2017-14722: Schwachstelle in WordPress ermöglicht Path-Traversal-Angriff

Im 'Customizer' von WordPress vor 4.8.2 existiert eine nicht näher
beschriebene Path-Traversal-Schwachstelle. Ein entfernter, nicht
authentisierter Angreifer kann diese ausnutzen, um einen
Path-Traversal-Angriff durchzuführen, wodurch er wahrscheinlich
Informationen ausspähen, Dateien manipulieren und sogar beliebigen
Programmcode zur Ausführung bringen kann.


CVE-2017-14721: Schwachstelle in WordPress ermöglicht
Cross-Site-Scripting-Angriff

Im 'Plugin Editor' von WordPress vor 4.8.2 existiert eine nicht näher
beschriebene Schwachstelle. Ein entfernter, nicht authentisierter Angreifer
kann diese ausnutzen, um einen Cross-Site-Scripting (XSS)-Angriff
durchzuführen.


CVE-2017-14720: Schwachstelle in WordPress ermöglicht
Cross-Site-Scripting-Angriff

In der 'Template Names'-Funktionalität von WordPress vor 4.8.2 existiert
eine nicht näher beschriebene Schwachstelle. Ein entfernter, nicht
authentisierter Angreifer kann diese ausnutzen, um einen
Cross-Site-Scripting (XSS)-Angriff durchzuführen.


CVE-2017-14719: Schwachstelle in WordPress ermöglicht Path-Traversal-Angriff

Im Programmcode zum Entpacken von Dateien in WordPress vor 4.8.2 existiert
eine nicht näher beschriebene Path-Traversal-Schwachstelle. Ein entfernter,
nicht authentisierter Angreifer kann diese ausnutzen, um einen
Path-Traversal-Angriff durchzuführen, wodurch er wahrscheinlich
Informationen ausspähen, Dateien manipulieren und sogar beliebigen
Programmcode zur Ausführung bringen kann.


CVE-2017-14718: Schwachstelle in WordPress ermöglicht
Cross-Site-Scripting-Angriff

In der 'Link Modal'-Funktionalität von WordPress vor 4.8.2 existiert eine
nicht näher beschriebene Schwachstelle. Ein entfernter, nicht
authentisierter Angreifer kann diese ausnutzen, um einen
Cross-Site-Scripting (XSS)-Angriff durchzuführen.


Referenzen:

Dieses Advisory finden Sie auch im DFN-CERT Portal unter:
<https://portal.cert.dfn.de/adv/DFN-CERT-2017-1802/>

WordPress 4.8.2 Release Notes:
<https://wordpress.org/news/2017/09/wordpress-4-8-2-security-and-maintenance-release/>

Schwachstelle CVE-2017-14718 (NVD):
<http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2017-14718>

Schwachstelle CVE-2017-14719 (NVD):
<http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2017-14719>

Schwachstelle CVE-2017-14720 (NVD):
<http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2017-14720>

Schwachstelle CVE-2017-14721 (NVD):
<http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2017-14721>

Schwachstelle CVE-2017-14722 (NVD):
<http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2017-14722>

Schwachstelle CVE-2017-14723 (NVD):
<http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2017-14723>

Schwachstelle CVE-2017-14724 (NVD):
<http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2017-14724>

Schwachstelle CVE-2017-14725 (NVD):
<http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2017-14725>

Schwachstelle CVE-2017-14726 (NVD):
<http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2017-14726>

Schwachstelle CVE-2017-14990 (NVD):
<http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2017-14990>

Debian Security Advisory DSA-3997-1:
<https://www.debian.org/security/2017/dsa-3997>


(c) DFN-CERT Services GmbH, all rights reserved!
Die Weiterverbreitung ist mit Hinweis auf den Copyrightinhaber innerhalb der
eigenen Einrichtung erlaubt. Eine darüber hinausgehende Verbreitung bedarf
des schriftlichen Einverständnisses des Rechteinhabers.

Ausgabe 11/2017

Digitale Ausgabe: Preis € 6,40
(inkl. 19% MwSt.)

Stellenmarkt

Artikelserien und interessante Workshops aus dem Magazin können Sie hier als Bundle erwerben.